Call for volunteers to run JAX-RS 1.1 TCK

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Call for volunteers to run JAX-RS 1.1 TCK

Mike Rheinheimer
Hi team,

My company will not allow me to sign the NDA to get and execute the
JAX-RS 1.1 TCK.  Would anyone be willing to volunteer to run the 1.1
TCK against the latest trunk build in preparation for Wink 1.1
release?  I'll take suggestions of whom to ask as well, of course.

Thanks much!
mike
Reply | Threaded
Open this post in threaded view
|

Re: Call for volunteers to run JAX-RS 1.1 TCK

Michael Elman
Administrator
I don't volunteer to run 1.1 TCK, since I'm not sure I'll have time to
install it.
Hopefully I'll have time to run 1.0 TCK.

But, I have a question. AFAIK JAX-RS 1.1 requires Servlet 3.0. As I see, the
dependencies for Wink 1.1 were not changed.
So my question is: did anyone try to run Wink 1.1 in Servlet 3.0
environment?


On Fri, Apr 9, 2010 at 5:50 PM, Mike Rheinheimer <[hidden email]> wrote:

> Hi team,
>
> My company will not allow me to sign the NDA to get and execute the
> JAX-RS 1.1 TCK.  Would anyone be willing to volunteer to run the 1.1
> TCK against the latest trunk build in preparation for Wink 1.1
> release?  I'll take suggestions of whom to ask as well, of course.
>
> Thanks much!
> mike
>
Reply | Threaded
Open this post in threaded view
|

Re: Call for volunteers to run JAX-RS 1.1 TCK

Bryant Luk
Thanks Michael.

I don't believe the Servlet 3.0 is required as a third party runtime.
There are statements that indicate running in a pre-Servlet 3.0
container.  However, I have no idea if the 1.1 TCK has any tests
specifically for it.  I think we can claim that we're aiming for
JAX-RS 1.1 compliance right now for this release if we can't get a 1.1
TCK run.

On Mon, Apr 26, 2010 at 8:06 AM, Michael Elman <[hidden email]> wrote:

> I don't volunteer to run 1.1 TCK, since I'm not sure I'll have time to
> install it.
> Hopefully I'll have time to run 1.0 TCK.
>
> But, I have a question. AFAIK JAX-RS 1.1 requires Servlet 3.0. As I see, the
> dependencies for Wink 1.1 were not changed.
> So my question is: did anyone try to run Wink 1.1 in Servlet 3.0
> environment?
>
>
> On Fri, Apr 9, 2010 at 5:50 PM, Mike Rheinheimer <[hidden email]> wrote:
>
>> Hi team,
>>
>> My company will not allow me to sign the NDA to get and execute the
>> JAX-RS 1.1 TCK.  Would anyone be willing to volunteer to run the 1.1
>> TCK against the latest trunk build in preparation for Wink 1.1
>> release?  I'll take suggestions of whom to ask as well, of course.
>>
>> Thanks much!
>> mike
>>
>
Reply | Threaded
Open this post in threaded view
|

Re: Call for volunteers to run JAX-RS 1.1 TCK

Nicholas L Gallardo

Right, servlet 3.0 isn't required.

Section 2.3.2 says that it is "RECOMMENDED that implementations support the Servlet 3 framework pluggability". In other words, they would like to see that 1.1 runtimes include a ContainerInitializer that the web container can then call during startup.

This should be one of the top priorities in the next release and is critical to our integration in Geronimo.

-Nick



Bryant Luk ---04/26/2010 09:36:14 AM---Thanks Michael.


To

[hidden email]

cc


Subject

Re: Call for volunteers to run JAX-RS 1.1 TCK

Thanks Michael.

I don't believe the Servlet 3.0 is required as a third party runtime.
There are statements that indicate running in a pre-Servlet 3.0
container.  However, I have no idea if the 1.1 TCK has any tests
specifically for it.  I think we can claim that we're aiming for
JAX-RS 1.1 compliance right now for this release if we can't get a 1.1
TCK run.

On Mon, Apr 26, 2010 at 8:06 AM, Michael Elman <[hidden email]> wrote:
> I don't volunteer to run 1.1 TCK, since I'm not sure I'll have time to
> install it.
> Hopefully I'll have time to run 1.0 TCK.
>
> But, I have a question. AFAIK JAX-RS 1.1 requires Servlet 3.0. As I see, the
> dependencies for Wink 1.1 were not changed.
> So my question is: did anyone try to run Wink 1.1 in Servlet 3.0
> environment?
>
>
> On Fri, Apr 9, 2010 at 5:50 PM, Mike Rheinheimer <[hidden email]> wrote:
>
>> Hi team,
>>
>> My company will not allow me to sign the NDA to get and execute the
>> JAX-RS 1.1 TCK.  Would anyone be willing to volunteer to run the 1.1
>> TCK against the latest trunk build in preparation for Wink 1.1
>> release?  I'll take suggestions of whom to ask as well, of course.
>>
>> Thanks much!
>> mike
>>
>

Reply | Threaded
Open this post in threaded view
|

Re: Call for volunteers to run JAX-RS 1.1 TCK

Michael Elman
Administrator
It's ok with me.
I just mentioned it, since Jersey 1.1.* has dependency on Servlet 3, and it
has some impact on TCK 1.1.
However, I'm not sure if it will cause any problems or not.

On Mon, Apr 26, 2010 at 5:50 PM, Nicholas L Gallardo <[hidden email]>wrote:

> Right, servlet 3.0 isn't required.
>
> Section 2.3.2 says that it is "RECOMMENDED that implementations support the
> Servlet 3 framework pluggability". In other words, they would like to see
> that 1.1 runtimes include a ContainerInitializer that the web container can
> then call during startup.
>
> This should be one of the top priorities in the next release and is
> critical to our integration in Geronimo.
>
> -Nick
>
>
>
> [image: Inactive hide details for Bryant Luk ---04/26/2010 09:36:14
> AM---Thanks Michael.]Bryant Luk ---04/26/2010 09:36:14 AM---Thanks
> Michael.
>
>
>     *Bryant Luk <[hidden email]>*
>
>             04/26/2010 09:35 AM
>             Please respond to
>             [hidden email]
>
>
> To
>
> [hidden email]
> cc
>
>
> Subject
>
> Re: Call for volunteers to run JAX-RS 1.1 TCK
>
> Thanks Michael.
>
> I don't believe the Servlet 3.0 is required as a third party runtime.
> There are statements that indicate running in a pre-Servlet 3.0
> container.  However, I have no idea if the 1.1 TCK has any tests
> specifically for it.  I think we can claim that we're aiming for
> JAX-RS 1.1 compliance right now for this release if we can't get a 1.1
> TCK run.
>
> On Mon, Apr 26, 2010 at 8:06 AM, Michael Elman <[hidden email]> wrote:
> > I don't volunteer to run 1.1 TCK, since I'm not sure I'll have time to
> > install it.
> > Hopefully I'll have time to run 1.0 TCK.
> >
> > But, I have a question. AFAIK JAX-RS 1.1 requires Servlet 3.0. As I see,
> the
> > dependencies for Wink 1.1 were not changed.
> > So my question is: did anyone try to run Wink 1.1 in Servlet 3.0
> > environment?
> >
> >
> > On Fri, Apr 9, 2010 at 5:50 PM, Mike Rheinheimer <[hidden email]>
> wrote:
> >
> >> Hi team,
> >>
> >> My company will not allow me to sign the NDA to get and execute the
> >> JAX-RS 1.1 TCK.  Would anyone be willing to volunteer to run the 1.1
> >> TCK against the latest trunk build in preparation for Wink 1.1
> >> release?  I'll take suggestions of whom to ask as well, of course.
> >>
> >> Thanks much!
> >> mike
> >>
> >
>
>